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Important Notice

COPYRIGHT
The material in this document is copyright to Fairlight ESP Pty Ltd., and may not be
quoted or reproduced in any form without written permission from the company.

Fairlight is a trademark of Fairlight ESP Pty Ltd. All other trademarks are the property
of their respective owners.

Plug-In parameter descriptions are included with kind permission of CreamWare
GmbH.

LIMITED WARRANTY POLICY
All the software and hardware provided with, or purchased especially for, Fairlight prod-
ucts has been tested for functionality. Fairlight ESP Pty Ltd. will make its best efforts to
correct reported defects for future releases subject to technical practicabilities. Fairlight
ESP will also replace any defective media on which software has been delivered provided
that the item to be replaced is returned to the dealer who supported the product within
90 days of purchase.

Fairlight ESP Pty Ltd. makes no warranty or representation either expressed or implied
with respect to the system's performance or fitness for a particular purpose.

In no event will Fairlight ESP Pty Ltd. be liable for direct or indirect damages arising
from any defect in the product or its documentation. Further, Fairlight ESP Pty Ltd. will
not accept any liability for any programs, sounds, audio recording or sequences stored in
or used with Fairlight products, including the cost of recovery of such data.

Product features and specifications are subject to change without notice. Fairlight ESP
reserves the right to change any part of this document without notice.

The warranties, remedies and disclaimers above are exclusive and take precedence over
all others, oral or written, express or implied, to the extent permitted by law in the geo-
graphical area of the product's use. No employee of Fairlight ESP, agent, distributor or
employee of an agent or distributor is authorized to offer any variation from this policy.

Copyright © 2003
Fairlight ESP Pty Ltd.,
Unit 2, 1 Skyline Place,
French's Forest, NSW 2086,
AUSTRALIA.
Telephone +61 2 8897 9999
Fax +61 2 8897 9900
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OBTAINING TECHNICAL SUPPORT
Users requiring technical support should contact their local Fairlight office or distrib-
utor. Information can also be found on the world wide web at:

http://www.fairlightesp.com
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Chapter 1 -  Introduction

INTRODUCTION
Fairlight Plug-Ins Manager 5 brings the flexibility of third-party plug-ins to the
DREAM family of mixing and editing systems. Plug-Ins Manager 5 is available
as an external Fairlight System Services Module application, or as an integrated
component of the DREAM Station or Console.

Plug-Ins Manager 5 offers support for a wide range of high performance real-
time plug-ins running on the dedicated Plug-Ins Manager, floating-point,
DSP card. The Plug-Ins Manager DSP card may be installed in the System
Services Module or directly within the DREAM Station or Console.

Plug-Ins Manager is seamlessly integrated into the DREAM mixer environ-
ment. Plug-ins may be selected and patched into feeds or buses to be added to
the mix in real-time or recorded to disk. Plug-ins parameters may be mapped
to and controlled from the switches pots and faders on the DREAM control
surface.

ABOUT THIS MANUAL
This manual provides all the information necessary to install and use Plug-Ins
Manager 5.

Follow the steps in the “Installation” chapter to successfully install and test the
Plug-Ins Manager system on either a Fairlight System Services Module or
within the DREAM Station or Console.

Read the “Using Plug-Ins” chapter for complete instructions on applying plug-
ins in your mixing session.

See the online version of this document included on your Plug-Ins Manager
CDROM for complete instructions on using all the standard plug-ins supplied
with the system. Click on the Start menu and select Programs>Fair-
light>Docs>Plug-In Manager Manual.

Check the Table of Contents or Index to quickly find the specific information
you need. When viewing this document on-screen, click on the hyperlinked
cross references to navigate through the document.
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Chapter 2 -  Instal lat ion

INTRODUCTION
Plug-Ins Manager 5 comprises the following components:

• Plug-Ins Manager DSP card (15DSP or 6DSP version)
• Plug-Ins Digital Audio Interface Board 
• Plug-Ins Manager 5 Software
• Optional Station/Console Mounting Kit

PIM 5 Requires DREAM V2.0
You must have successfully completed an upgrade to DREAM Software ver-
sion 2.0 prior to installing Plug-Ins Manager 5.0. Check the V2.0 release notes
for upgrade instructions.

Installation Summary
The installation procedure includes the following steps, summarised below,
which are detailed in this chapter:

1. Install drivers for the Fairlight AIB USB device.
2. Install Plug-Ins Manager hardware in either the SSM, Station or DREAM 

Console.
3. Install drivers for the plug-ins DSP card.
4. Install the Scope Fusion Platform Software.
5. Install Plug-Ins Manager 5 Software on both Station or Console and 

SSM, if used.
6. Place a short-cut to Plug-Ins Manager in your start-up directory.
7. Edit System_Variables.txt to specify physical I/O for plug-ins.
8. Use the DREAMStart Setup page to configure the Fairlight Mixing Con-

sole application.
9. Edit the FlexiSurface.txt file to specify which physical controls will be 

mapped to the plug-in parameters.
PIM 5 REQUIRES DREAM V2.0
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CD Contents
The CD contains the following files and directories:

• Drivers  - directory containing AIB USB drivers, included in case you have
problems using the automatic setup file.

• SFP - directory containing the CreamWare Scope Fusion Platform Instal-
lation files.

• SetupPIMDrivers-####.exe - the AIB USB driver setup file.

• SetupMSAT-####.exe - Fairlight Monitoring System and Automated
Testing application included to assist in troubleshooting and mapping new
plug-ins.

• SetupSFP-####.bat - Scope Fusion Platform setup file.

• SetupAcrobatReader-####.exe - Adobe Acrobat Reader setup file for
viewing the documentation.

• SetupPIMDocs-####.exe - Plug-Ins Manager User Manual setup file.

• SetupPIM-####.exe - Plug-Ins Manager Setup file.
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ADMINISTRATOR LOG-ON
Make sure you are logged on as Administrator before performing any instal-
lation tasks. Administrator is the default user for all DREAM systems. If no
users have been set up on your system, skip this section.

Step 1 If installing the plug-ins hardware in the Station or DREAM 
Console. Quit FMC, if necessary, by holding down the Shift key 
and pressing the Pause/Break key and click on the Exit but-
ton on the DREAM Start splash screen if currently running.

Step 2 Click on the Start button then click Shut Down.

Step 3 Click the drop-down list and examine the entry that reads 
Log off .... If the name is Administrator, click the Cancel 
button, you are already logged on as administrator. 

If you are logged on with another log-on name, select the Log 
off ... item and click OK.

Step 4 When the log-on window is displayed, hold down the Ctrl, Alt 
and Del keys as instructed.

Step 5 When the username and password window is displayed, enter 
Administrator as the username. The default password is 
dream. Consult you system administrator for the correct pass-
word and domain settings.

Step 6 Click OK to log on to the system.

USB DRIVER INSTALLATION
Installing the Fairlight AIB USB driver before installing the hardware simpli-
fies the installation process. The USB driver must be installed in the device in
which the plug-ins hardware will be installed, either a Fairlight System Services
Module (SSM), or Station or DREAM Console.

Step 1 If installing the plug-ins hardware in the Station or DREAM 
Console. Quit FMC, if necessary, by holding down the Shift key 
and pressing the Pause/Break key then type q y. Click on the 
Exit button on the DREAM Start splash screen if currently run-
ning.
CD CONTENTS



2-5
Step 2 Insert the PIM5 CD into the CDROM drive. Click on My 
Computer on the Windows desktop. 

Step 3 Navigate to the CDROM and double click on the SetupPIM-
Drivers file The PIM Driver Installer will run displaying the PIM 
installation Welcome screen.

Step 4 Click Next, then click Next again to start copying the files.

Step 5 Click the Finish button to quit the installer when finished.

The system will now automatically identify the AIB USB device when installed
and load the appropriate drivers.

HARDWARE INSTALLATION
The Plug-Ins Manager hardware may be installed in either a Fairlight System
Services Module, or directly within the Station or DREAM Console. To install
the Plug-Ins Manager in a Station or DREAM Console you will require the
optional Station/Console Plug-Ins installation kit.

Read the sections below then move on to the relevant hardware installation sec-
tion.

Tools Required
• #1 Pozidrive screwdriver
• #2 Pozidrive screwdriver
• 5mm nut driver
HARDWARE INSTALLATION
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Equipment Supplied

8PIM-15DSP Plug-Ins Kit

EQUIPMENT 
SUPPLIED

PART
NUMBER

QTY
CHECK 

LIST

PIM Installation Manual DSSM004-B 1

PIM Software CD 
Including User Manual

7PIMV5.0 1

Registration Key Card 1

AIB USB/DC Cable Assembly APIM102-D 1

Plug-Ins/AIB Audio Bus Cable APIM201-A 1

MIX-AIB AES Audio Interface 
Card c/w CPU card

BMIX042A-A 1

Fairlight 15 DSP Plug-Ins Card GEC8438 1

D connector screw lock Kit FSM8260 1
EQUIPMENT SUPPLIED
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8PIM-6DSP Plug-Ins Kit

EQUIPMENT 
SUPPLIED

PART
NUMBER

QTY
CHECK 

LIST

PIM Installation Manual DSSM004-B 1

PIM Software CD 
Including User Manual

7PIMV5.0 1

Registration Key Card 1

AIB USB/DC Cable Assembly APIM102-D 1

Plug-Ins/AIB Audio Bus Cable APIM201-A 1

MIX-AIB AES Audio Interface 
Card c/w CPU card

BMIX042A-A 1

Fairlight 6 DSP Plug-Ins Card GEC8427 1

D connector screw lock Kit FSM8260 1
HARDWARE INSTALLATION
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1PIM-INST Station/Console PIM Mounting Kit

EQUIPMENT 
SUPPLIED

PART
NUMBER

QTY
CHECK 

LIST

AIB-SBO USB/DC
Cable Assembly

ABE1205-A 1

PIM Mounting Bracket MBE1005-B 1

PCI Rear Support Bracket MBE1006-C 1

PCI Riser Card BMIX155A-A 1

Mounting Screw Kit including:
7 x M3x6mm pozi-drive screws
5 x M4x10mm pozi-drive screws
2 x M3x8mm nylon standoff
2 x M3 nylon nut/washers
2 x M3x12mm male/female hex 
spacers

1

128Mb 168 Pin PC133 RAM SMM6799 1
EQUIPMENT SUPPLIED
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Static Precautions
Do not open or remove components from your system unless specifically
instructed to do so. Please take note that all Fairlight manufactured electronic
modules are static sensitive and should be handled under anti-static conditions.
When working on a system always ensure that you have an anti-static lead con-
nected.

Never work on the system while powered up unless you are authorized by Fair-
light to do so. As a matter of practice always touch the external chassis of the
system before opening the unit. If cards are not handled under anti-static pro-
cedures your machine may sustain damage which could either cause a complete
failure or may cause intermittent crashes and subsequent system failure.

When handling cards please ensure that they are placed in anti-static bags when
not in the system. For shipment purposes electronic modules should be placed
in an anti-static bag and then suitably surrounded with loose packaging mate-
rials in a solid card board box. Cards shipped to Fairlight without the correct
anti-static packaging will have their warranty voided. If you have any enquiries
on this matter please feel free to contact your local Fairlight office or distrib-
utor. 

Unpacking
Check the contents of your plug-ins kit against the list above and make a note
of any omissions.

SSM INSTALLATION
Step 1 Power down the SSM and remove the top cover.

Step 2 To mount the AIB card hardware. Insert the 50-pin D connector 
through the cut-out in the rear panel of the SSM. Attach the con-
nector with the two D connector screwlock fittings supplied. Use 
a 5mm nut driver or small adjustable spanner to tighten the fit-
tings.

Step 3 Install the DSP Card card into the first available PCI slot. Secure 
the card with the mounting screw removed from the SSM blank-
ing plate.
SSM INSTALLATION
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Step 4 Connect the AIB USB/Power cable (APIM102-D). Connect the 
DC connector to a free power supply DC connector. Connect the 
USB header to the motherboard USB2 connector as shown below 
(note that connections may be different on some motherboards):

PCI Slot 1
DSP Card 

USB2
UNPACKING
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Figure 1: SSM Motherboard Connectors

Figure 2: USB Connection Detail (may differ on some motherboards)
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Step 5 Connect the DSP-AIB Audio Bus Cable. Note the orientation of 
the cable as shown below.

Figure 3: SSM Cable Connections

Step 6 Connect a 50-pin AES I/O cable from the AIB to a spare digital 
I/O connector on the QDC engine. See “Digital I/O Connector” 
on page 4-2 for connector pin-out.

Step 7 Re-attach the SSM top cover.

Step 8 Plug-Ins Manager communicates with the Station or console via 
TCP/IP. Connect the SSM via a 100BaseT ethernet hub to the 
Station or Console and QDC engine. See “Network Settings” on 
page 2-30 for configuration details.

Now move to “Software Installation” on page 2-24.

of card. 
Red wire to front

Attach cable to
front connector.

DSP Card

DC power connection

FRONT

USB/DC connector Audio bus connector
UNPACKING
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STATION INSTALLATION 
Step 1 Power down the Station.

Step 2 Remove the top panel of the Station by first removing the four 
M4 retaining screws at the front and the three retaining screws at 
the rear just below the top panel.

Step 3 Carefully lift off the top panel. Note that the panel is connected 
to the base by two internal cables.

Step 4 Disconnect the trackball cable connection from the motherboard 
and the USB/power cable connection from the top panel PCB.

Carefully place the top panel in a safe location. Rest the panel on 
its edge. UNDER NO CIRCUMSTANCES SHOULD THE 
ROTARY ENCODERS REST AGAINST ANY SURFACE.

Step 5 Remove the blanking panel from the 50-pin D-connector cut-out 
on the rear panel of the Station by unscrewing the two M3 
screws.

Step 6 Attach the nylon spacer to the PCI rear support bracket with an 
M3 screw. 

Step 7 Attach the PCI rear support bracket to the threaded standoffs 
next to the CDROM drive with two M4 screws.

M4 Mounting Screws

Nylon Spacer
STATION INSTALLATION
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Step 8 On a flat surface, assemble the mounting bracket, PCI riser card 
and DSP card as shown in the picture below. Insert the two M3 
screws as shown. 

Figure 4: Bracket/PCI Riser/DSP Card Assembly

Step 9 Carefully lift the assembly and insert it into the Station as indi-
cated. Lift the keyboard cable to allow the mounting bracket to 
line up with the mounting hole in the rear panel. Make sure the 
mounting bracket is aligned with the two standoffs on the Station 
base and that the bracket is not obstructed by any of the existing 
cables. Adjust the cables if necessary.

Step 10 Align the hole in the end of the DSP card with the nylon spacer 
on the PCI rear support bracket. Attach the DSP card with  one 
M3 nylon nut.

M3 Screw

M3 Screw PCI Riser Card
UNPACKING
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Step 11 Carefully insert the PCI riser card into the PCI slot in the moth-
erboard and press down firmly until the card is fully inserted in 
the PCI edge connector.

Figure 5: Bracket/PCI Riser/DSP Card Installation

Step 12  Secure the bracket by inserting one M4 retaining screw through 
the Station rear panel.

Insert the remaining two M4 retaining screws through the top of 
the bracket into the threaded standoffs on the Station base plate.

Step 13 Attach the AIB card to the mounting bracket by inserting the 50-
pin connector through the rear panel cut-out. Attach the AIB 
card to the bracket with the two M3 screws provided.

Finally, insert the two D connector screw-lock posts through the 
rear panel of the Station into the 50-pin D connector. Tighten 

M4 Bracket Screws

SBO USB/DC Connector

PCI Edge Connector

Keyboard Cable

RAM SIMM
STATION INSTALLATION
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the screw-lock posts with a 5mm nut driver or small adjustable 
spanner. 

Figure 6: Mounting Detail - Screws at Rear of Station

Step 14 Install the USB/DC cable (ABE1205-A) from the AIB card to the 
spare connector on the SBO card as shown.

M4 Bracket retaining screw

AIB D connector screw lock posts
UNPACKING
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Step 15 Install the audio bus cable (APIM201-A), note the orientation of 
the cable as shown.

Figure 7: AIB and cable installation

Step 16 Install the new 128MB RAM SIMM into the motherboard. 
Insert the SIMM into the edge connector making sure of correct 
orientation. Use the retaining clips in the connector to secure the 
SIMM.

Audio bus cable, 
red wire to FRONT

USB/DC cable 

FRONT 

of card

AIB mounting screws
STATION INSTALLATION
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Step 17 Re-attach the upper section of the Station.

First re-connect the trackball cable to the motherboard, then 
reconnect the USB/power cable to the top panel PCB.

Step 18 Carefully replace to top panel and re-attach the seven retaining 
screws.

DREAM CONSOLE INSTALLATION
Step 1 Power down the console.

Step 2 Undo the retaining screws securing the rear of the console CPU 
tray. On a five bay console the CPU tray is at the right viewed 
from the rear, in a three bay console it is in the centre. Carefully 
slide the tray out as far as possible.

Step 3 Attach the two nylon spacers to the PCI rear support bracket with 
two M3 screws.

Step 4 Attach the PCI rear support bracket to the threaded standoffs 
next to the CDROM drive with two M4 screws.

M4 Mounting Screws

Nylon spacers
should be 
located here
UNPACKING
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Step 5 On a flat surface, assemble the mounting bracket, PCI riser card 
and DSP card as shown in the picture below. Insert the two M3 
screws as shown. Insert the two male/female M3 standoffs into 
the bracket.

Figure 8: Bracket/PCI Riser/DSP Card Assembly

Step 6 Carefully lift the assembly and insert it into the CPU tray as indi-
cated. Make sure the mounting bracket is aligned with the two 
stand-offs on the base of the tray and that the bracket is not 
obstructed by any of the existing cables. Adjust the cables if neces-
sary.

M3 Screw

M3 Screw PCI Riser Card

Insert M/F 
Standoffs Here
DREAM CONSOLE INSTALLATION
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Step 7 Carefully insert the PCI riser card into the PCI slot in the moth-
erboard and press down firmly until the card is fully inserted in 
the PCI edge connector.

Figure 9: Bracket/PCI Riser/DSP Card Installation

 Secure the bracket by inserting one M4 retaining screw through 
the heatsink on the rear panel of the tray. On early consoles this 
hole may be obscured by the heatsink. In this case, insert the 
screw from the inside of the bracket so that it extends about 3mm 
into the hole from the inside of the CPU tray.

SBO USB/DC 

M4 Bracket Screws

PCI Edge 

RAM 

Connector

SIMM

Connector

Support
Bracket
UNPACKING
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Insert the remaining two M4 retaining screws through the top of 
the bracket into the threaded standoffs on the base of the tray.

Step 8 Align the two holes in the end of the DSP card with the nylon 
spacers on the PCI rear support bracket. Attach the DSP card 
with the two M3 nylon nuts.

Step 9 Attach the AIB card to the bracket via the two M3 standoffs, 
secured with two M3 screws. Insert the final screw into threaded 
insert on the side of the CPU tray.

Step 10 Install the USB/DC cable (ABE1205-A) from the AIB card to 
connector JR3 on the SBO card as shown.

Figure 10: SBO USB/DC Connector
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for Plug-Ins
DREAM CONSOLE INSTALLATION
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Step 11 Install the audio bus cable (APIM201-A), note the orientation of 
the cable as shown.

Figure 11: AIB and cable installation

Step 12 Install the new 128MB RAM SIMM into the motherboard. 
Insert the SIMM into the edge connector making sure of correct 
orientation. Use the retaining clips in the connector to secure the 
SIMM.

Audio bus cable, 
red wire to FRONT

USB/DC Cable 

FRONT 

of card

AIB Mounting
Screws
UNPACKING
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Step 13 Check that all cables are still secure and slide the CPU tray closed. 
Re-insert the retaining screws in the tray.
DREAM CONSOLE INSTALLATION
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SOFTWARE INSTALLATION
Once the hardware has been installed, restart your SSM, Station or Console.
Make sure the system is running DREAM software version 2.0 or higher prior
to installing the Plug-Ins system. The software version is displayed in the
BLUE Utils menu.

Station/Console BIOS Settings
During boot-up of the Station or Console, hold down the Del key to display
the BIOS setup screen.

Step 1 Select Integrated Peripherals > System Share Memory 
Size >32MB.

Step 2 Save and Exit.

CreamWare Driver Installation
During boot-up the operating system will detect new hardware.

When the Found New Hardware dialogue for the Creamware DSP card is
displayed, insert the PIM Install disk. Select Search for a suitable driver
for my device and check the CD ROM option. Select the drivers, when
prompted, located on the PIM Install in SFP\Driver\Win2k\scopeWDM.inf.

If a Found New Hardware dialogue for the USB AIB card is displayed,
insert the Plug-Ins Manager 5 disk, select Search for a suitable driver for
my device and check the CD ROM option. Select the drivers, when
prompted, located on the PIM 5 CD in Drivers\FairUSB.inf.

Pulsar Software Installation
The Plug-Ins Manager system runs on a customised version of the Creamware
Scope Fusion Platform, that is supplied on the PIM5 CD. It is NOT possible
to run PIM5 with any other versions of Creamware software.

Step 1 Click on the Exit button on the DREAM Start splash screen if 
currently running.

Step 2 Insert the PIM Install CD.
STATION/CONSOLE BIOS SETTINGS
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Step 3 Click on My Computer on the Windows desktop and navigate 
to the CDROM. Double click on SetupSFP-###.bat file located 
in the root directory of the CDROM.

Step 4 Select the Language, and click Next when prompted, then at the 
Readme file and License agreement click Accept if you accept 
the terms of the agreement.

Step 5 Select the default installation Folder C:\SFP and click Next. Do 
not alter this path.

Step 6 If installing a 6 DSP card, select the package named Pulsar.

OR

If installing a 15 DSP card, select the package name Scope.

Step 7 Check the Product Activation Keys card that is supplied with the 
Plug-Ins kit. This card contains the activation keys for the 
CreamWare DSP card and all the software Plug-Ins supplied with 
the Plug-Ins Manager.

To activate each product, click in the enter key field next to the 
products listed in the dialog box and enter the keys from the 
labels on the card. Retain this card in a safe place for future refer-
ence.

Click Next.

Step 8 When prompted to Select the VST Plugins folder for 
XTC components, leave the text boxes blank or click the Dis-
able buttons to clear them, then Next.

Step 9 Finally, click Finish.

PIM5 Software Installation
Plug-Ins Manager 5 must now be installed.

Step 1 Insert the Plug-Ins Manager 5 CD. Click on My Computer on 
the Windows desktop. Navigate to the CDROM and double 
click on the SetupPIM file. The PIM 5 Installer will run display-
ing the PIM installation Welcome screen.

Step 2 Click Next, then read the End User License Agreement. If you 
accept the agreement, click Yes. 
SOFTWARE INSTALLATION
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Step 3 Click Next to start copying the files.

Step 4 Click the Finish button to quit the installer when finished.

Documentation Installation
The on-line version of this manual includes additional chapters on using all the
plug-ins supplied with Plug-Ins Manager. Once installed the manual can be
found by clicking on the Start menu and selecting Programs > Fairlight
> Docs

User Manual
Step 1 Insert the Plug-Ins Manager 5 CD. Click on My Computer on 

the Windows desktop. Navigate to the CDROM and double 
click on the SetupPIMDocs file. The PIM 5 Documentation 
Installer will run displaying the PIM installation Welcome 
screen.

Step 2 Click Next to start copying the files.

Step 3 Click the Finish button to quit the installer when finished.

Acrobat Reader
Step 1 Insert the Plug-Ins Manager 5 CD. Click on My Computer on 

the Windows desktop. Navigate to the CDROM and double 
click on the SetupAcrobatReader file. The PIM 5 Documentation 
Installer will run displaying the PIM installation Welcome 
screen.

Step 2 Click Next to start copying the files.

Step 3 Acrobat Reader Installer will run. Follow the prompts to set up 
Adobe Acrobat Reader.

Step 4 Click the Finish button to quit the installer when finished.
DOCUMENTATION INSTALLATION
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SSM Installation
If running Plug-Ins Manager on an SSM you must also install Plug-Ins Man-
ager on the Station or Console. This is necessary only to install the plug-ins,
flexiSurface maps and ancillary PIM components. The Plug-Ins Manager
application itself, only runs on the SSM but the installation must be performed
on the Station or Console. If running Plug-Ins Manager in the Station or Con-
sole, ignore this step.

Step 1 Click on the Exit button on the DREAM Start splash screen if 
currently running.

Step 2 Insert the Plug-Ins Manager 5 CD in the Station or Console CD 
ROM drive. Click on My Computer on the Windows desktop. 
Navigate to the CDROM and double click on the SetupPIM file 
The PIM 5 Installer will run displaying the PIM installation 
Welcome screen.

Step 3 Click Next, then read the End User License Agreement. If you 
accept the agreement, click Yes. 

Step 4 Click Next to start copying the files.

Step 5 Click the Finish button to quit the installer when finished.

Step 6 Restart the Station or Console computer. Click on the Start 
Menu and select Shutdown > Restart.

Add Startup Shortcut
Adding Plug-Ins Manager to the startup directory will make Plug-Ins Manager
run automatically every time you start up your system.

Step 1 Right click on the task bar at the bottom of the Windows desk-
top.

Step 2 Click Properties, then click on the Advanced tab.

Step 3 Click the Add button, then click the Browse button and navi-
gate to C:\Program Files\Fairlight\Plug-In Manager\Plug-In Man-
ager.exe.

Step 4 Click Next then scroll down the destination folder list to Start 
Menu > Programs > Startup, then click Next.
SOFTWARE INSTALLATION
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Step 5 Click Next to accept the shortcut name, then click Finish.

If running Plug-ins Manager internally on a Station or Console, the short-cut
properties must be set to Run Minimized. For SSM systems, the short-cut is
set to Run Maximized.

Step 1 Click on the Start menu and right click Programs > Startup > 
Plug-In Manager and select Properties from the context 
menu.

Step 2 Click on the Run: drop-down list and select Minimzed or 
Maximized, as appropriate for you system.

Add System Variables
The QDC I/O used to support Plug-Ins must now be defined. Plug-Ins
requires a block of 16 AES I/O.

Step 1 On the Station or Console, click on My Computer on the Win-
dows desktop and navigate to C:\Program Files\Fair-
light\FMC\Data\System_Variables.txt. Double click on the file to 
open it in the Windows Notepad editor.

Step 2 Edit the following lines:

PLUGINS_IO_START,1
PLUGINS_IO_RANGE,16

The plug-ins I/O takes up a block of 16 AES I/Os. The start 
number should be 1, 17, or 33 depending on which I/O in your 
system you wish to use.

Step 3 Save the file and exit Notepad. 
ADD SYSTEM VARIABLES
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DREAMStart Setup
The DREAMStart application is used to configure the Fairlight Mixing Con-
sole application for use with plug-ins.

Figure 12: DreamStart Setup Page

Step 1 Click on the Start button on the Windows desktop and select 
Programs>Fairlight>DREAMStart.

Step 2 Click on the Setup binnacle key on the DREAMStart display to 
access the DREAM Setup page.

Step 3 Click on the Plug-ins Setup drop-down list in the DREAM 
Surface Options section of the Setup page. Select INTERNAL 
for running plug-ins internally in your Station or Console. Select 
EXTERNAL for running plug-ins in an SSM.

Step 4 If running plug-ins in an SSM, enter the IP address of the SSM in 
the Plug-ins IP Address field. This field is ignored if running 
plug-ins internally. See Network Settings below.

Step 5 Click OK to accept changes and exit the setup page.
SOFTWARE INSTALLATION
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Network Settings
If running Plug-Ins Manager in a Fairlight System Services Module PC, make
sure that the SSM is connected to the Station or Console via a 100BaseT eth-
ernet hub and that the IP address is within the same subnet and unique.

Figure 13: SSM Network Settings

To configure the SSM network settings follow these steps:

Step 1 Right click on My Network Places on the Windows desktop 
to open the Network and Dial-up Connections dialogue box. 
Select Properties.

Double click Local Area Connection, then click Proper-
ties.

Double click TCP/IP and set the SSM's IP address. Ensure the IP 
address is unique and within the subnet range of the engine and 
console. It is common practice to set the last number in the SSM 
IP address to a value 100 higher than the Console or Station. For 
example, if the Station or Console’s IP address is 10.1.1.111, 
make the SSM IP address 10.1.1.211.

Step 2 Press Tab to get the default Subnet Mask 255.255.255.0, 
then click OK.

Step 3 Tick the Show icon in taskbar box, then click OK and 
Close.
NETWORK SETTINGS
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FlexiSurface File
By default, all plug-in parameters are mapped to faders, pan and mute controls
on the first twelve faders of a Console or Sidecar. No changes to the FlexiSur-
face configuration are required, however, sophisticated customisation is pos-
sible using the FlexiSurface system. 

If no Sidecar is available in a Station system the FlexiSurface file may need to
be modified. 

The FlexiSurface file defines which physical controls on the control surface are
available to be mapped to control plug-in parameters. Parameters may be
mapped to pan, mute and fader controls on a fader panel or Sidecar, or to the
rotary controls and switches on the parameter pad of a Station. 

To edit the file click on the Start menu and select Programs>Accesso-
ries>Notepad. File>Open from the Notepad menu and navigate to
C:\Program Files\Fairlight\FMC\Data\FlexiSurface.txt and open the file.

When mapping to a fader panel edit the file to select the target fader strips.
Each fader strip must be listed in the file with an entry, for example, FADER-
STRIP,1. The default flexisurface maps include twelve faders. Any number
of faders may be used, however, each plug-in FlexiSurface map file must be
modified to suit the configuration.

When mapping to the Station Parameter Pad the file merely contains one
PARAPAD entry, all FADERSTRIP entries must be removed. The plug-in
FlexiSurface map files must be modified to suit this configuration.

See the FlexiSurface Maps chapter in the PIM 5 User Manual for more details.

Restart System
Step 1 You must now restart your computer. Click on the Start Menu 

and select Shutdown > Restart.
SOFTWARE INSTALLATION
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Starting Plug-Ins Manager
Plug-Ins Manager 5 must be started prior to launching FMC. To start Plug-
Ins Manager, click on the Start menu and select Programs>Fairlight
ESP>Plug-In Manager.

A short-cut to Plug-Ins Manager should be added to the Windows Startup
directory as described above. This causes Plug-Ins Manager to run automati-
cally when the system is powered on. For Stations or Consoles running In-
Screen, the short-cut properties are set to Run Minimized. For SSM systems,
the short-cut is set to Run Maximized. 

Once Plug-Ins Manager is running you may proceed to start FMC from
DREAMStart in the normal manner.
STARTING PLUG-INS MANAGER
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Chapter 3 -  Using Plug-Ins

INTRODUCTION
Plug-ins are inserted into feeds from the insert menu. This provides consider-
able flexibility allowing plug-ins to be inserted directly into a track feed, or into
a live feed whose input is sourced from an auxiliary bus, for example. This
allows the Aux Bus to drive the plug-in, with the return being the Live Feed in
which the plug-in is inserted.

Starting Plug-Ins
Plug-Ins Manager must be started prior to launching FMC. Plug-Ins Manager
may be launched from the Start menu, or by copying a shortcut to the Win-
dows Startup directory. Follow the steps in the installation chapter to get the
system working.

PATCHING A PLUG-IN
Both stereo and mono plug-ins are supported. Stereo plug-ins may be inserted
across a stereo link group. If a stereo plug-in is inserted on a mono feed, the
right channel is inserted in the adjacent feed.

Step 1 Call the feed on which you wish to insert a plug-in.

Step 2 Press the Insert key on Station or Insert Config on Console to 
display the Insert menu.

Step 3 Press the Add Plug-In soft key.

Step 4 Use the jog wheel or arrow keys to scroll through the list of avail-
able plug-ins.

Step 5 Press the Add soft key to instantiate the plug-in in Plug-Ins Man-
ager.

There may be some delay while the plug-in instantiates. The 
insert patching is displayed on the channel display at the bottom 
of the mixer display and the insert is switched in. A small purple 
P in the channel tile of the selected feed indicates that it has a 
plug-in.
STARTING PLUG-INS
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When running plug-ins in-screen on Station or Console, the 
plug-in is displayed on top of the mixer display.

When running on an SSM the plug-in is displayed in the Plug-
Ins manager window on the SSM display.

Step 6 When using a plug-in that has a valid FlexiSurface map file, the 
plug-in parameters may be controlled from the fader panel or 
Sidecar by pressing the Plug-Ins key located below the Parame-
ter Pad on Station or between the Direct Config and SIP 
Defeat keys at the top of the Channel Panel on Console.

Parameters are mapped to the Pan, Mute and Fader controls on a 
fader panel on the Console or Sidecar, or to the rotary controls 
and switches on the Parameter Pad. See the FlexiSurface Maps 
chapter for details on custom maps.

Step 7 To remove a plug-in, press the Remove Plug-In soft key in 
the Insert menu.

CONTROLLING PLUG-INS
Plug-in parameters can be controlled using the trackball when running in the
Station or Console, or the mouse when running in an SSM, or from the phys-
ical controls of the control surface. The mapping of parameters to controls is
configured in a special mapping file which is described in the FlexiSurface
Maps chapter. Default mapping files are supplied for all supplied plug-ins.

The Plug-Ins key on the Parameter Pad on Station, or Channel Panel on
Console is dimly lit if the called feed has a plug-in inserted. Pressing the Plug-
Ins key will display the plug-in graphical interface on screen, and the faderset
map on the control surface as described below.

Using the Trackball
When running plug-ins internally in the Station or Console, the trackball can
be used to control the plug-in’s graphical interface. When running in an SSM,
the SSM’s mouse can be used.

Once a plug-in is inserted in a feed, its graphical interface is displayed on the
screen whenever the feed is called and the Plug-Ins key on the Parameter Pad
CONTROLLING PLUG-INS
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on Station or Channel Panel on Console is pressed. Use the mouse to click and
drag on any parameter control. 

To gain more resolution when controlling a knob, click in the centre of the
knob then move the pointer to the top edge of the screen, then move the
pointer from left to right to adjust the value.

Using the Control Surface
Plug-in parameters can be controlled from the fader, mute and pan controls on
a fader panel or Sidecar, or from the encoders and switches on the Station
Parameter Pad. The default FlexiSurface mapping places each parameter under
the control of an appropriate fader, rotary encoder or switch.

Once a plug-in is inserted in a feed, its graphical interface is displayed on the
screen whenever the feed is called and the Plug-Ins key is pressed.

The parameter names are displayed in the LCD windows above the faders or
next to the controls in the Parameter Pad. Changes made to any parameter via
the control surface are displayed in the plug-ins graphical interface.

The selection of a specific group of faders, or the Parameter Pad for use with
plug-ins is made in the FlexiSurface file. See “FlexiSurface File” on page 2-31.

FAVOURITES
The FAV favourites soft key in the Insert menu displays a list of user selected
plug-ins. This allows the user to quickly find the plug-ins they use most often
without having to scroll through the entire list of available plug-ins.

Each user has their own unique favourites list. If you have logged on to the
system as a different user, your favourites list will not be available.

Adding to Favourites
Step 1 Press the Insert key on Station or Insert Config on Console to 

display the Insert menu.

NOTE: Do not click on the cross at the top right of a plug-in 
graphical interface. Always use the Remove Plug-In soft key 
in the Insert menu to remove plug-ins.
USING THE CONTROL SURFACE
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Step 2 Press the Add Plug-In soft key.

Step 3 Press the ALL soft key to display the complete list of plug-ins on 
your system.

Step 4 Turn the jog wheel to scroll down the list of available plug-ins and 
find the one you wish to add.

Step 5 Press the ADD TO FAV soft key to add the plug-in the favourites 
list.

Selecting Favourites
Step 1 Call the feed on which to insert a plug-in.

Step 2 Press the Insert key on Station or Insert Config on Console to 
display the Insert menu.

Step 3 Press the Add Plug-In soft key.

Step 4 Press the Fave soft key to display the favourites list.

Step 5 Turn the jog wheel to scroll down the list of favourite plug-ins.

Step 6 Press the Add soft key to insert the plug-in.

APPROVED 3RD PARTY PLUG-INS
Fairlight maintains a list of approved third-party plug-ins which have been
tested and verified for stable operation and good performance on the DREAM
Plug-Ins Manager system. Check the Plug-Ins Manager page on the Fairlight
web site at www.fairlight.net for details of the latest plug-ins.

Adding New Plug-Ins
Follow the instructions included with the plug-in you have purchased, and any
special instructions provided on the Fairlight web site. The plug-in device file
must be copied to the C:\SFP\Devices\Fairlight\PlugIns directory. Plug-ins
device files are named with either a .mdl or .dev file extension. Your new plug-
in will now appear in the All plug-ins list in the Insert menu.
APPROVED 3RD PARTY PLUG-INS
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Chapter 4 -  Specif ications

CONNECTIONS

Digital I/O Connector
Description: 16 balanced pairs AES/EBU digital audio.

Note - to connect to a standard QDC 50 pin digital I/O connector, wire cable
pin 1 to pin 1, pin 2 to pin 2, and so on.

Connector: 50 pin D female

+ GND - Channel #

17 33 50 Digital Output 1/2
16 32 49 Digital Output 3/4
15 31 48 Digital Output 5/6
14 30 47 Digital Output 7/8
13 29 46 Digital Input 1/2
12 28 45 Digital Input 3/4
11 27 44 Digital Input 5/6
10 26 43 Digital Input 7/8
9 25 42 Digital Output 9/10
8 24 41 Digital Output 11/12
7 23 40 Digital Output 13/14
6 22 39 Digital Output 15/16
5 21 38 Digital Input 9/10
4 20 37 Digital Input 11/12
3 19 36 Digital Input 13/14
2 18 35 Digital Input 15/16
DIGITAL I/O CONNECTOR
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APIM102-D
Description: DC and USB connection for SSM installation of AIB card.

Note - USB connections may vary on some motherboards.

Connectors: 

CN1 - 6-pin Molex 39-01-2060 (Farnell 151-868) with Crimp Pins 39-00-
0039 (Farnell 151-890).

CN2 - 5-pin FCI 65039-032 (Farnell 528-481) with Crimp Pins FCI 47750-
00 (Farnell 528-560).

CN3 - 4-pin AMP 1-480426-0 (Farnell 299-479) with Crimp Pins AMP
163305-2 (Farnell 299-558)

CN1 Signal Wire CN2 CN3

1 USBD+ L-2B2AT Orange 3 NC
2 GND Braid 4 NC
3 Spare Brown 5 NC
4 USBD- L-2B2AT white 2 NC
5 GND Black NC 3
6 Vcc Red NC 4

CN2 pin 1 not connected
CN3 pin 1,2 not connected
CONNECTIONS
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ABE1205-A
Description: DC and USB connection from SBO card to AIB card in Station
and Console.

Connectors: 6-pin Molex 39-01-2060 (Farnell 151-868) with Crimp Pins 39-
00-0039 (Farnell 151-890).

CN1 Signal Wire CN2

1 USBD+ L-2B2AT Orange 1
2 GND Braid 2
3 Spare NC 3
4 USBD- L-2B2AT white 4
5 GND Black 5
6 Vcc Red 6
ABE1205-A



Index-i
Index

Symbols
.dev . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-5
.mdl . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-5

Numerics
1PIM-INST Station/Console PIM Mounting Kit . . . . . . 2-8
3rd Party Plug-ins . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-5
50-pin Connector Wiring . . . . . . . . . . . . . . . . . . . . . . 4-2
8PIM-15DSP Plug-Ins Kit . . . . . . . . . . . . . . . . . . . . . . 2-6
8PIM-6DSP Plug-Ins Kit . . . . . . . . . . . . . . . . . . . . . . . 2-7

A
Add Plug-In  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-2
Adding New Plug-Ins . . . . . . . . . . . . . . . . . . . . . . . . . 3-5
Approved 3rd Party Plug-Ins  . . . . . . . . . . . . . . . . . . . 3-5
Automation  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-4

B
Bracket  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-14, 2-19

C
Cable Installation . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-17
Connector Wiring  . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-2
Console Installation . . . . . . . . . . . . . . . . . . . . . . . . . . 2-18
Controlling Plug-Ins . . . . . . . . . . . . . . . . . . . . . . . . . . 3-3

D
DC connector  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-10
Documentation  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-26

F
Favourites  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-4

H
Help  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-26

I
I/O Wiring . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-2
Insert  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-2
Insert Config  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-2, 3-4, 3-5
INDEX



Index-ii
M
Mapping Parameters . . . . . . . . . . . . . . . . . . . . . . . . . . 3-5
Motherboard Connectors . . . . . . . . . . . . . . . . . . . . . . 2-11

P
Patching a Plug-In  . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-2
PCI Riser  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-14, 2-19
Plug-Ins  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-3

R
RAM SIMM  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-17, 2-22
Remove Plug-In  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-3

S
SSM Installation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-9
Static Precautions . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-9
Station Installation  . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-13
Supplied Equipment . . . . . . . . . . . . . . . . . . . . . . . . . . 2-6

T
Tools Required . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-5
Trackball  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-3

U
USB Connection  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-11
INDEX



Index-iii
INDEX




	Table of Contents
	Chapter 1 - Introduction
	Introduction
	About This Manual

	Chapter 2 - Installation
	PIM 5 Requires DREAM V2.0
	Installation Summary
	CD Contents
	Administrator Log-on
	USB Driver Installation
	Hardware Installation
	Tools Required
	Equipment Supplied
	Static Precautions
	Unpacking

	SSM Installation
	Station Installation
	DREAM Console Installation
	Software Installation
	Station/Console BIOS Settings
	CreamWare Driver Installation
	Pulsar Software Installation
	PIM5 Software Installation
	Documentation Installation
	SSM Installation
	Add Startup Shortcut
	Add System Variables
	DREAMStart Setup
	Network Settings
	FlexiSurface File
	Restart System
	Starting Plug-Ins Manager


	Chapter 3 - Using Plug-Ins
	Introduction
	Starting Plug-Ins

	Patching a Plug-In
	Controlling Plug-Ins
	Using the Trackball
	Using the Control Surface

	Favourites
	Adding to Favourites
	Selecting Favourites

	Approved 3rd Party Plug-ins
	Adding New Plug-Ins
	Connections
	Digital I/O Connector
	APIM102-D
	ABE1205-A




	Index

